[Sakai Jira] Commented: (SAKIII-4367) Build error when using -Psakai-release

Kent Fitzgerald (JIRA) sakai-ui-dev-tracking at collab.sakaiproject.org
Mon Nov 28 10:24:55 PST 2011


    [ https://jira.sakaiproject.org/browse/SAKIII-4367?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=143172#comment-143172 ] 

Kent Fitzgerald commented on SAKIII-4367:
-----------------------------------------

printenv now shows:
JAVA_HOME=/usr/lib/jvm/java-6-sun-1.6.0.26
PATH contains $JAVA_HOME/bin

I still get the same error for 3akai-ux when running:
mvn clean install -Psakai-release

I'm not sure it will help, but I ran a quick test and from the terminal I added the simple HelloWorld.java example. I then ran javac HelloWorld.java and it made the requisite .class file and I could run the java program. 

> Build error when using -Psakai-release
> --------------------------------------
>
>                 Key: SAKIII-4367
>                 URL: https://jira.sakaiproject.org/browse/SAKIII-4367
>             Project: Sakai 3 UI Dev
>          Issue Type: Bug
>          Components: Core UI development
>    Affects Versions: Sprint 115, 1.1.0
>         Environment: qa20-us.sakaiproject.org
>            Reporter: Kent Fitzgerald
>            Assignee: Yushan Li
>            Priority: Blocker
>             Fix For: Sprint 116, 1.1.0
>
>
> I am getting a build error on qa20-us.sakaiproject.org when building with mvn clean install -Psakai-release. 
> It started Friday evening. Prior to that, the same build command worked fine. I can build successfully using mvn clean install (without the release profile)
> I originally got errors on two environments, but my local environment is no longer giving errors and builds successfully. Bert reported he got a different error when executing:
> -P redeploy build
> unpackMathFonts:
>      [echo] Not unpacking MathJax Font images, Math formulas on FireFox versions prior to 3.5 will not be supported!
>    [delete] Deleting: /home/sakai/src/3akai-ux/target/processed-resources/dev/lib/MathJax/fonts/HTML-CSS/TeX/png.zip
>    [delete] Deleting: /home/sakai/src/3akai-ux/target/processed-resources/dev/lib/MathJax/config/local/imageFonts.js
> compile_hash_tool:
>    [delete] Deleting directory /home/sakai/src/3akai-ux/tools/hashfiles/HashAndRefreshFiles/classes
>     [mkdir] Created dir: /home/sakai/src/3akai-ux/tools/hashfiles/HashAndRefreshFiles/classes
>     [javac] /home/sakai/src/3akai-ux/build.xml:257: warning: 'includeantruntime' was not set, defaulting to build.sysclasspath=last; set to false for repeatable builds
>     [javac] Compiling 1 source file to /home/sakai/src/3akai-ux/tools/hashfiles/HashAndRefreshFiles/classes
> [INFO] ------------------------------------------------------------------------
> [ERROR] BUILD ERROR
> [INFO] ------------------------------------------------------------------------
> [INFO] An Ant BuildException has occured: The following error occurred while executing this line:
> /home/sakai/src/3akai-ux/build.xml:257: Unable to find a javac compiler;
> com.sun.tools.javac.Main is not on the classpath.
> Perhaps JAVA_HOME does not point to the JDK.
> It is currently set to "/usr/lib/jvm/java-6-sun-1.6.0.26/jre"
> [INFO] ------------------------------------------------------------------------
> [INFO] For more information, run Maven with the -e switch
> [INFO] ------------------------------------------------------------------------
> [INFO] Total time: 7 minutes 6 seconds
> [INFO] Finished at: Mon Nov 28 14:18:16 UTC 2011
> [INFO] Final Memory: 16M/179M
> [INFO] ------------------------------------------------------------------------
> Is there a new dependency? I'll try cleaning out my local .m2 repo and building fresh as well. 

-- 
This message is automatically generated by JIRA.
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        


More information about the sakai-ui-dev-tracking mailing list